LWPM Comfort Module

  • Status Closed
  • Percent Complete
    100%
  • Task Type Błąd
  • Category Konfigurator
  • Assigned To
    LWPM
  • Operating System wszystkie
  • Priority Very Low
  • Reported Version v0.6
  • Due in Version konfigurator
  • Votes
  • Private
Attached to Project: LWPM Comfort Module
Opened by marcinsu - 04.04.2019
Last edited by LWPM - 05.04.2019

FS#305 - Błąd podczas zapisu akcji

Hej,

Podczas próby zapisu akcji “Przednie światła mijania + AFL” wywala błąd:
DEV ERR> !!! unhandled EXCEPTION !!!
DEV ERR> Traceback (most recent call last):

File "lcm_service.py", line 266, in EXECUTE
File "lcm_service.py", line 1046, in fun
File "lcm_service.py", line 1046, in 

ValueError: non-hexadecimal number found in fromhex() arg at position 22

Po pobraniu akcji z katalogu, poszczególnie sekwencje są oddzielone spacją.
Zapis się udał po usunięciu wszystkich białych znaków.

Closed by  LWPM
05.04.2019 11:01
Reason for closing:  Naprawione

Tzn pobrales akcje z katalogu i nie szlo zapisac a po usunieciu spacji juz jest ok?

Masz vc czy ah lub zb?

Mozliwe ze jest blad w akcji i zamiast spacji wkradly sie inne znaki niewidoczne. Blednie tez akcja podzielona jest spacjami. Cos sie posypalo albo w katalogu albo w konfiguratorze.

AH.

Podczas pisania tego ticketa nie zwróciłem uwagi że jest już wersja 0.6.
Możliwe że problem z zapisem został wyeliminowany (sprawdzę później).

Wyglądało to tak że pobieram z katalogu akcje, klikam zapisz, dalej zapisz do urządzenia -> wywalało błąd. Nie mogłem już nic więcej zrobić.
Dopiero po odłączeniu i podłączeniu UART można było połączyć się z modułem.

Teraz plik lcm_service zmalał o jakąś połowę, może trochę został przepisany / zoptymalizowany.
Napiszę pod koniec dnia.

Może biały znak to nie spacja była i nie został usunięty.

No na próbę pobralem ta akcje z katalogu i jest dziwnie podzielona na spacje, nie jest podzielona poleceniami. Takze mozliwe ze wlasnie ktorys znak nie jest spacja.

Ok, potwierdzam w wersji 0.6 - błąd pojawia się podczas zapisu "Przednie światła mijania + AFL" i ponownie trzeba odłączyć i podłączyć moduł.

Po usunięciu znaków białych - przechodzi.

Admin
LWPM commented on 05.04.2019 11:00

poprawione - spacja była w nieodpowiednim miejscu

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing